Back to overview
Downtime
Voice Services are having issues
Feb 02 at 08:50am EST
Affected services
Voice360
ITP Voice
Resolved
Feb 02 at 10:55am EST
We have identified the root cause of the issue. A complete report of the incident is available here: https://itp360.com/reports/ITP_RFO_Feb_2_2024.pdf
Affected services
Voice360
ITP Voice
Created
Feb 02 at 08:50am EST
We are experiencing issues passing VoIP traffic with our Session Border Controllers. This can affect your ability to make or receive calls.
Affected services
Voice360
ITP Voice