Back to overview
Degraded
Power Outage
Feb 04 at 11:54am EST
Affected services
ITP Fiber Internet Services
Resolved
Feb 04 at 12:11pm EST
FPL has restored power in the area.
Affected services
ITP Fiber Internet Services
Created
Feb 04 at 11:54am EST
There is a massive power outage in the Coral Gables area affecting some internet customers. FPL is currently working in the area to restore power.
Affected services
ITP Fiber Internet Services